Prompted for Windows Authentication using JBoss/Tomcat

Jun 5, 2013 at 1:56 PM
I have an evironment I am trying to setup using WAFFLE, but i continue to get a Windows authentication pop-up bic when I try to access the application. Here is the server-side log:


2013-06-05 08:36:28,637 INFO [waffle.servlet.NegotiateSecurityFilter] GET /public_html/controller, contentlength: -1
2013-06-05 08:36:28,637 INFO [waffle.servlet.NegotiateSecurityFilter] authorization required
2013-06-05 08:36:28,652 INFO [waffle.servlet.NegotiateSecurityFilter] GET /public_html/controller, contentlength: -1
2013-06-05 08:36:28,652 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] security package: Negotiate, connection id: 10.64.4.34:50692
2013-06-05 08:36:28,668 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] token buffer: 2843 byte(s)
2013-06-05 08:36:28,824 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] continue token: oXwweqADCgEBoQsGCSqGSIL3EgECAqJmBGRgYgYJKoZIhvcSAQICAwB+UzBRoAMCAQWhAwIBHqQRGA8yMDEzMDYwNTEzMzYyOFqlBQIDBHEOpgMCASmpERsPQ0NDLkNPT1BDQU0uQ09NqhMwEaADAgEBoQowCBsGYXBwdHJp
2013-06-05 08:36:28,824 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] continue required: true
2013-06-05 08:36:28,840 INFO [waffle.servlet.NegotiateSecurityFilter] GET /public_html/controller, contentlength: -1
2013-06-05 08:36:28,840 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] security package: Negotiate, connection id: 10.64.4.34:50692
2013-06-05 08:36:28,840 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] token buffer: 2786 byte(s)
2013-06-05 08:36:28,840 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] continue token: oW8wbaADCgEBomYEZGBiBgkqhkiG9xIBAgIDAH5TMFGgAwIBBaEDAgEepBEYDzIwMTMwNjA1MTMzNjI4WqUFAgMErhemAwIBKakRGw9DQ0MuQ09PUENBTS5DT02qEzARoAMCAQGhCjAIGwZhcHB0cmk=
2013-06-05 08:36:28,840 INFO [waffle.servlet.spi.NegotiateSecurityFilterProvider] continue required: true



Here are my settings in the web.xml for WAFFLE:
<!-- ================== WAFFLE Filter Configuration ==================== --> <filter>
    <filter-name>WaffleSecurityFilter</filter-name>
    <filter-class>waffle.servlet.NegotiateSecurityFilter</filter-class>
    <init-param>
      <param-name>principalFormat</param-name>
      <param-value>fqn</param-value>
    </init-param>
   <init-param>
     <param-name>roleFormat</param-name>
     <param-value>both</param-value>
   </init-param>
   <init-param>
     <param-name>allowGuestLogin</param-name>
     <param-value>false</param-value>
   </init-param>
   <init-param>
     <param-name>securityFilterProviders</param-name>
     <param-value>waffle.servlet.spi.NegotiateSecurityFilterProvider</param-value>
   </init-param>
   <init-param>
     <param-name>waffle.servlet.spi.NegotiateSecurityFilterProvider/protocols</param-name>
     <param-value>Negotiate</param-value>
   </init-param>
 </filter>
 <filter-mapping>
   <filter-name>WaffleSecurityFilter</filter-name>
   <url-pattern>/*</url-pattern>
 </filter-mapping>

This JBoss configuration, including these WAFFLE settings, are a direct copy from another installation that does work properly.

When we put in the user/password credentials into the pop-up, we just get propmpted for them again. In fact this happens several times, then it will give us a separate authentication error page.

The browser is already set with the "Enable Windows Intergrated Authentication" as checked, and the application server has been added to the Local Intranet zone.

Any ideas?

Thanks in Advance!
Coordinator
Jun 5, 2013 at 2:01 PM
WAFFLE HAS MOVED TO GITHUB

DONT POST HERE - GO HERE. The new home is http://dblock.github.com/waffle/.