Waffle-negotiate example dosn't work

Mar 25, 2011 at 4:09 PM

Hi there,



I installed the waffle samples as you have discribed. The waffle-negotiate example (in which i'm interested) is not working it returns a blank page. I'm using tomcat version 6.0 .32

The following are Tomcat logs when I'm trying to access to http://localhost:8080/waffle-negotiate in the browser:

Mar 25, 2011 4:27:56 PM waffle.apache.NegotiateAuthenticator authenticate
FINE: GET /waffle-negotiate/, contentlength: -1
Mar 25, 2011 4:27:56 PM waffle.apache.NegotiateAuthenticator authenticate
FINE: authorization: <none>, ntlm post: false
Mar 25, 2011 4:27:56 PM waffle.apache.NegotiateAuthenticator authenticate
FINE: authorization required

 Any idea what could be the problem? Let me know if you need more information to investigate the problem. 

Thanks in advance,

Kamil

Coordinator
Mar 26, 2011 at 4:52 AM

Most likely this is a client-side problem. Start here

Mar 28, 2011 at 10:09 AM

Thanks for the reply,

I have added my site ( http://localhost:8080 ) in the Intranet zone list in my browser (IE 8 & Firefox 3.6) as described in the provided link above.

But I still have exactly the same result.

Any help or advice will be appriciated.

Thanks in advance.

Kamil.

Coordinator
Mar 28, 2011 at 2:21 PM

There's a section in that link that says:

Still Need Help?

Trace the HTTP request/response.

  1. Download and install IEHttpHeaders.
  2. Choose Tools, Display IEHttpHeaders.
  3. Make one request that ends up in a popup or failure.
  4. Copy the entire HTTP conversation.

Post the http conversation with your question into discussions.

Mar 28, 2011 at 4:34 PM

GET /waffle-negotiate/ HTTP/1.1
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Language: en-us
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.6; chromeframe/10.0.648.204; .NET CLR 2.0.50727; FDM; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)
Accept-Encoding: gzip, deflate
Host: localhost:8080
Connection: Keep-Alive

HTTP/1.1 404 Not Found
Server: Apache-Coyote/1.1
Pragma: No-cache
Cache-Control: no-cache
Expires: Thu, 01 Jan 1970 02:00:00 EET
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
Connection: close
Transfer-Encoding: chunked
Date: Mon, 28 Mar 2011 15:32:07 GMT

 

Coordinator
Mar 28, 2011 at 4:47 PM

You have a 404 file not found response. This should be 401 access denied. This means something is passing through authentication instead of terminating there. This means there's a problem in your tomcat configuration - I would get it to work with a stock tomcat and then compare with what you have.

Mar 29, 2011 at 2:15 PM

I have downloaded a fresh tomcat-6.0.32, copied required jar files to the lib dir and copied the waffle-negotiate example to the webapps dir and launch my tomcat from the commad line (startup).

Finally I am getting the same result regardless of the localhost url is in the intranet zone of the browser or not.

Please advise me if I am doing something wrong.

Thanks in advance.

Coordinator
Mar 29, 2011 at 2:22 PM
Edited Mar 29, 2011 at 2:23 PM

I think you might be having the same problem from the FAQ as here - which is the 1.3 distribution missing a 401.html file (which is our fault of course). If that's not the problem, examine the HTTP trace again. You need a 401 access denied followed by at least 2 authorization headers for Negotiate and NTLM.