(Tomcat/Generic Filter) How to disable Waffle logging?

Mar 1, 2011 at 12:51 AM
Edited Mar 1, 2011 at 12:56 AM

Not being too familiar with commons logging, is there an easy way to disable all the INFO logging that goes on?  In production environs, I'd like to only have SEVERE.  I've played with the logging.properties file in Tomcat's conf dir but can't seem to figure it.

For example, I'd like the following to not be logged.  It logs one of these for every resource requested from the server.

 

01/03/2011 12:49:01 PM waffle.servlet.NegotiateSecurityFilter doFilter
INFO: POST /FigtreeWeb5/Messages, contentlength: 0
01/03/2011 12:49:01 PM waffle.servlet.spi.NegotiateSecurityFilterProvider isPrincipalException
INFO: authorization: Negotiate YHYGBisGAQUFAqBsMGqgMDAuBgorBgEEAYI3AgIKBgkqhkiC9xIBAgIGCSqGSIb3EgECAgYKKwYBBAGCNwICHqI2BDROVExNU1NQAAEAAACXsgjiBgAGAC4AAAAGAAYAKAAAAAYBsB0AAAAPVE9CWVBDRklHQVVT, ntlm post: false
01/03/2011 12:49:01 PM waffle.servlet.NegotiateSecurityFilter doFilterPrincipal
INFO: previously authenticated Windows user: FIGAUS\joe.bloggs

 

PS.  dblock, this is a fantastic library.  I've just replaced all our JEE IWA/SSO mechanisms with Waffle!  Was easy as pie :)

Coordinator
Mar 1, 2011 at 1:37 PM

You're in the right place. You should be able to do this in logging.properties.

waffle.servlet.level = ERROR

Mar 1, 2011 at 10:22 PM

Thanks I'll give it a try.

Mar 3, 2011 at 1:14 AM

Unfortunately that didn't work.  I still get those 6 lines for every resource requested by the client ... and that amounts to a huge number of lines in the log :(

Just to confirm exactly what I did:-

In "tomcat/conf/logging.properties" I added the following line and re-started Tomcat

waffle.servlet.level = ERROR


Any other ideas? I'd rather not have to mess with the WAFFLE source if I can avoid it.

Thankyou

Mar 3, 2011 at 3:32 AM

FYI ... Setting it to SEVERE did what I needed.

Thanks