Jboss 6.0 and waffle java.lang.ClassNotFoundException: waffle.servlet.spi.BasicSecurityFilterProvider

Feb 3, 2011 at 7:25 PM
Edited Feb 4, 2011 at 3:22 AM

 Hi,

      Can any one Please let me know that we can use Waffle Frame work with Jboss 5.X or not ?. I am able to do that with 4.X. i am trying to use Waffle with Jboss 5.X/6.X i am getting the following error can any one help me out.

Exception starting filter SecurityFilter: java.lang.RuntimeException: java.lang.ClassNotFoundException: waffle.servlet.spi.BasicSecurityFilterProvider waffle.servlet.spi.NegotiateSecurityFilterProvider from BaseClassLoader@909419{vfs:///C:/DEV/jboss-6.0.0/server/default/deploy/Test.war}
    at waffle.servlet.spi.SecurityFilterProviderCollection.<init>(Unknown Source) [:]
    at waffle.servlet.NegotiateSecurityFilter.init(Unknown Source) [:]
    at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:447) [:6.0.0.Final]
    at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3246) [:6.0.0.Final]
    at org.apache.catalina.core.StandardContext.start(StandardContext.java:3843) [:6.0.0.Final]
    at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:294) [:6.0.0.Final]
    at org.jboss.

 

i appreciate  any help. Thanks

Coordinator
Feb 4, 2011 at 12:36 AM

Looks like your waffle JARs aren't in the right place. They should be in the location of the global classloader, but I don't know where that is in JBoss. 

Feb 4, 2011 at 3:19 AM
Edited Feb 4, 2011 at 3:21 AM

Thanks for the response

Feb 4, 2011 at 3:49 PM

We run JBoss 5.1.0_GA, and our jars are in .../application.ear/APP-INF/lib.

Feb 4, 2011 at 7:33 PM

memeister ...i tried with EAR file also but still  the same error is coming.

14:26:36,480 INFO  [TomcatDeployment] deploy, ctxPath=/jmx-console
14:26:36,668 INFO  [TomcatDeployment] deploy, ctxPath=/FinalWeb
14:26:36,746 INFO  [SecurityFilterProviderCollection] loading 'waffle.servlet.spi.BasicSecurityFilterProvider waffle.servlet.spi.NegotiateSecurityFilterProvider'
14:26:36,746 ERROR [SecurityFilterProviderCollection] error loading 'waffle.servlet.spi.BasicSecurityFilterProvider waffle.servlet.spi.NegotiateSecurityFilterProvider': waffle.servlet.spi.BasicSecurityFilterProvider waffle.servlet.spi.NegotiateSecurityFilterProvider from BaseClassLoader@c4bca9{VFSClassLoaderPolicy@3e0d14{name=vfszip:/C:/DEV/jboss-5.0.1.GA/server/default/deploy/Final.ear/FinalWeb.war/ domain=ClassLoaderDomain@1a1c1f5{name=vfszip:/C:/DEV/jboss-5.0.1.GA/server/default/deploy/Final.ear/FinalWeb.war/ parentPolicy=AFTER_BUT_JAVA_BEFORE parent=BaseClassLoader@b056fd{vfszip:/C:/DEV/jboss-5.0.1.GA/server/default/deploy/Final.

i have included waffle-jna.jar,waffle-jacob.jar,platform.jar,jna.jar in the war Lib

i am not able to find what is missing. Thanks

 

Mar 31, 2011 at 10:43 PM

What did you do about context.xml?  I have a problem getting jboss 5,1,0 to start when using a context.xml file.  If you are using one, when did you put it?

Apr 1, 2011 at 5:28 PM

We use context.xml to do mutually-authenticated SSL, and put it in the WEB-INF directory.