Class version of WAFFLE

Jun 16, 2010 at 9:25 AM
WAFFLE was build with a class version for Java 6. That it work not with older Java VM's. Is it possible to compile it with a class version for Java 5. You can do it with the Ant Javac flag target="1.5"
Jun 16, 2010 at 11:37 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jun 16, 2010 at 11:38 AM

I'll take a look. JNA is still compatible with 1.5, so this should work in theory.

Jun 16, 2010 at 2:47 PM

This was committed. Please try build 1.3.4197.0. Let me know if it works.

Jun 20, 2010 at 12:19 PM


I had tried the latest version. It works like a charm in Java 6.

But fails with - " Bad Version " in Java 5. Is it possible to get this to get compiled in java5 and give out a separate version ?

Thanks in advance.

Jun 20, 2010 at 3:57 PM

I'll take a look. For faster delivery, you can always make the changes in source code and send me a a patch :)

Jun 21, 2010 at 2:21 PM

I fixed a method that borrowed from 1.6. Please try build 1.3.4393.0. I tested with JRE 1.5.0_04. If it still doesn't work, please post the full error, stack trace and version(s) of Java that you have.

Jul 2, 2010 at 11:15 AM
String.isEmpty() is also a Java 6 method.
Jul 2, 2010 at 8:56 PM

Fixed. I changed my environment to use Java 1.5 just to make sure :)